The install instructions here pull from pip, not the cloned project. pyproject.toml exists, but you can't run a pip install -e. What am I missing?
python3 -m pip install -e .
ERROR: File "setup.py" not found. Directory cannot be installed in editable mode: /home/xxxxx/contact
(A "pyproject.toml" file was found, but editable mode currently requires a setup.py based build.)
The install instructions here pull from pip, not the cloned project. pyproject.toml exists, but you can't run a pip install -e. What am I missing?
python3 -m pip install -e .
ERROR: File "setup.py" not found. Directory cannot be installed in editable mode: /home/xxxxx/contact
(A "pyproject.toml" file was found, but editable mode currently requires a setup.py based build.)
<!-- github-sync-id:3214028750 -->
Hmm, possible this is because I am attempting an install on Ubuntu 20.04, which ships with Python 3.8.10.
Did a pip install . (-e did not work) and this is the result
Installing build dependencies ... error
ERROR: Command errored out with exit status 1:
command: /usr/bin/python3 /usr/lib/python3/dist-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-fjgih2jf/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- 'poetry-core>=2.0.0,<3.0.0'
cwd: None
Complete output (2 lines):
ERROR: Could not find a version that satisfies the requirement poetry-core<3.0.0,>=2.0.0 (from versions: 1.0.0a0, 1.0.0a1, 1.0.0a2, 1.0.0a3, 1.0.0a4, 1.0.0a5, 1.0.0a6, 1.0.0a7, 1.0.0a8, 1.0.0a9, 1.0.0b1, 1.0.0rc1, 1.0.0rc2, 1.0.0rc3, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.1.0a1, 1.1.0a2, 1.1.0a3, 1.1.0a4, 1.1.0a5, 1.1.0a6, 1.1.0a7, 1.1.0b1, 1.1.0b2, 1.1.0b3, 1.1.0rc1, 1.1.0rc2, 1.1.0rc3, 1.1.0, 1.2.0, 1.3.0, 1.3.1, 1.3.2, 1.4.0, 1.5.0, 1.5.1, 1.5.2, 1.6.0, 1.6.1, 1.7.0, 1.8.0, 1.8.1, 1.9.0, 1.9.1)
ERROR: No matching distribution found for poetry-core<3.0.0,>=2.0.0
ERROR: Command errored out with exit status 1: /usr/bin/python3 /usr/lib/python3/dist-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-fjgih2jf/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- 'poetry-core>=2.0.0,<3.0.0' Check the logs for full command output.
Hmm, possible this is because I am attempting an install on Ubuntu 20.04, which ships with Python 3.8.10.
Did a pip install . (-e did not work) and this is the result
Installing build dependencies ... error
ERROR: Command errored out with exit status 1:
command: /usr/bin/python3 /usr/lib/python3/dist-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-fjgih2jf/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- 'poetry-core>=2.0.0,<3.0.0'
cwd: None
Complete output (2 lines):
ERROR: Could not find a version that satisfies the requirement poetry-core<3.0.0,>=2.0.0 (from versions: 1.0.0a0, 1.0.0a1, 1.0.0a2, 1.0.0a3, 1.0.0a4, 1.0.0a5, 1.0.0a6, 1.0.0a7, 1.0.0a8, 1.0.0a9, 1.0.0b1, 1.0.0rc1, 1.0.0rc2, 1.0.0rc3, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.1.0a1, 1.1.0a2, 1.1.0a3, 1.1.0a4, 1.1.0a5, 1.1.0a6, 1.1.0a7, 1.1.0b1, 1.1.0b2, 1.1.0b3, 1.1.0rc1, 1.1.0rc2, 1.1.0rc3, 1.1.0, 1.2.0, 1.3.0, 1.3.1, 1.3.2, 1.4.0, 1.5.0, 1.5.1, 1.5.2, 1.6.0, 1.6.1, 1.7.0, 1.8.0, 1.8.1, 1.9.0, 1.9.1)
ERROR: No matching distribution found for poetry-core<3.0.0,>=2.0.0
----------------------------------------
ERROR: Command errored out with exit status 1: /usr/bin/python3 /usr/lib/python3/dist-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-fjgih2jf/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- 'poetry-core>=2.0.0,<3.0.0' Check the logs for full command output.
<!-- github-comment-id:3054470113 -->
Yeah, I think updating to Python 3.9 might help you. I forget the reasoning but I did list 3.9 as a requirement in pyproject.toml.
Yeah, I think updating to Python 3.9 might help you. I forget the reasoning but I did list 3.9 as a requirement in pyproject.toml.
<!-- github-comment-id:3070035361 -->
Blocking a user prevents them from interacting with repositories, such as opening or commenting on pull requests or issues. Learn more about blocking a user.
The install instructions here pull from pip, not the cloned project. pyproject.toml exists, but you can't run a pip install -e. What am I missing?
python3 -m pip install -e .
ERROR: File "setup.py" not found. Directory cannot be installed in editable mode: /home/xxxxx/contact
(A "pyproject.toml" file was found, but editable mode currently requires a setup.py based build.)
I don't know much about packaging but
pip install -e .works for me (without thepython3 -m)python 3.11.8
Hmm, possible this is because I am attempting an install on Ubuntu 20.04, which ships with Python 3.8.10.
Did a pip install . (-e did not work) and this is the result
Installing build dependencies ... error
ERROR: Command errored out with exit status 1:
command: /usr/bin/python3 /usr/lib/python3/dist-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-fjgih2jf/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- 'poetry-core>=2.0.0,<3.0.0'
cwd: None
Complete output (2 lines):
ERROR: Could not find a version that satisfies the requirement poetry-core<3.0.0,>=2.0.0 (from versions: 1.0.0a0, 1.0.0a1, 1.0.0a2, 1.0.0a3, 1.0.0a4, 1.0.0a5, 1.0.0a6, 1.0.0a7, 1.0.0a8, 1.0.0a9, 1.0.0b1, 1.0.0rc1, 1.0.0rc2, 1.0.0rc3, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.1.0a1, 1.1.0a2, 1.1.0a3, 1.1.0a4, 1.1.0a5, 1.1.0a6, 1.1.0a7, 1.1.0b1, 1.1.0b2, 1.1.0b3, 1.1.0rc1, 1.1.0rc2, 1.1.0rc3, 1.1.0, 1.2.0, 1.3.0, 1.3.1, 1.3.2, 1.4.0, 1.5.0, 1.5.1, 1.5.2, 1.6.0, 1.6.1, 1.7.0, 1.8.0, 1.8.1, 1.9.0, 1.9.1)
ERROR: No matching distribution found for poetry-core<3.0.0,>=2.0.0
ERROR: Command errored out with exit status 1: /usr/bin/python3 /usr/lib/python3/dist-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-fjgih2jf/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- 'poetry-core>=2.0.0,<3.0.0' Check the logs for full command output.
Yeah, I think updating to Python 3.9 might help you. I forget the reasoning but I did list 3.9 as a requirement in pyproject.toml.