It seems we need to upgrade to the latest jQuery 3.x version to get this fixed. It will break Piwigo code in many parts, so I don't want to do it for Piwigo 2.10.
I don't know how problematic this vulnerability is. I may change my mind if I see a real problem related to it.
It seems we need to upgrade to the latest jQuery 3.x version to get this fixed. It will break Piwigo code in many parts, so I don't want to do it for Piwigo 2.10.
I don't know how problematic this vulnerability is. I may change my mind if I see a real problem related to it.
<!-- github-comment-id:504929518 -->
Adding this so you know how bad this can be, which isn't super bad but still concerning.
Our security scanning software, Nessus, picked up on this vulnerability in the current version of the default theme.
It pointed to CVE-2020-11022 which states that jquery allows for untrusted code to be executed in versions 1.2 and later and before version 3.5.0. It is fixed in version 3.5.0 and later.
Adding this so you know how bad this can be, which isn't super bad but still concerning.
Our security scanning software, Nessus, picked up on this vulnerability in the current version of the default theme.
It pointed to [CVE-2020-11022](https://nvd.nist.gov/vuln/detail/cve-2020-11022) which states that jquery allows for untrusted code to be executed in versions 1.2 and later and before version 3.5.0. It is fixed in version 3.5.0 and later.
<!-- github-comment-id:1850253531 -->
Blocking a user prevents them from interacting with repositories, such as opening or commenting on pull requests or issues. Learn more about blocking a user.
default installation 2.9.5 have vulnerable jquery - https://snyk.io/vuln/npm:jquery?lh=1.11.3&utm_source=lighthouse&utm_medium=ref&utm_campaign=audit
It seems we need to upgrade to the latest jQuery 3.x version to get this fixed. It will break Piwigo code in many parts, so I don't want to do it for Piwigo 2.10.
I don't know how problematic this vulnerability is. I may change my mind if I see a real problem related to it.
Adding this so you know how bad this can be, which isn't super bad but still concerning.
Our security scanning software, Nessus, picked up on this vulnerability in the current version of the default theme.
It pointed to CVE-2020-11022 which states that jquery allows for untrusted code to be executed in versions 1.2 and later and before version 3.5.0. It is fixed in version 3.5.0 and later.