I've just lived a very bad experience with upgrade of another web application (let's call it webApp), but it could have happened to Piwigo too! I'm using PHP 5.4 on this environement. The requirement for WebApp 2.16.5 was PHP version 5.3 and WebApp proposed me to upgrade to version 2.17. I agreed and the upgrade started. Unfortunately, WebApp 2.17 now requires PHP 5.5. My installation of WebApp is frozen.
We should implement a "pre-upgrade" check. On PHP and MySQL versions at least.
I've just lived a very bad experience with upgrade of another web application (let's call it webApp), but it could have happened to Piwigo too! I'm using PHP 5.4 on this environement. The requirement for WebApp 2.16.5 was PHP version 5.3 and WebApp proposed me to upgrade to version 2.17. I agreed and the upgrade started. Unfortunately, WebApp 2.17 now requires PHP 5.5. My installation of WebApp is frozen.
We should implement a "pre-upgrade" check. On PHP and MySQL versions at least.
<!-- github-sync-id:196664651 -->
Blocking a user prevents them from interacting with repositories, such as opening or commenting on pull requests or issues. Learn more about blocking a user.
I've just lived a very bad experience with upgrade of another web application (let's call it webApp), but it could have happened to Piwigo too! I'm using PHP 5.4 on this environement. The requirement for WebApp 2.16.5 was PHP version 5.3 and WebApp proposed me to upgrade to version 2.17. I agreed and the upgrade started. Unfortunately, WebApp 2.17 now requires PHP 5.5. My installation of WebApp is frozen.
We should implement a "pre-upgrade" check. On PHP and MySQL versions at least.