As described on https://piwigo.org/forum/viewtopic.php?id=31263 some users have received security warnings when using PHP 7.4. Updating PHPMailer to version 5.2.28 seems to remove the warning.
PHPMailer 5.2.28 is the latest version of branch 5.2 but there are much more recent versions 6.x. Piwigo does not include them because it would imply increasing the minimum PHP version to 5.5 at least, or maybe 7. We can plan that for Piwigo 12 or 13.
As described on https://piwigo.org/forum/viewtopic.php?id=31263 some users have received security warnings when using PHP 7.4. Updating PHPMailer to version 5.2.28 seems to remove the warning.
PHPMailer 5.2.28 is the latest version of branch 5.2 but there are much more recent versions 6.x. Piwigo does not include them because it would imply increasing the minimum PHP version to 5.5 at least, or maybe 7. We can plan that for Piwigo 12 or 13.
<!-- github-sync-id:897992984 -->
Blocking a user prevents them from interacting with repositories, such as opening or commenting on pull requests or issues. Learn more about blocking a user.
As described on https://piwigo.org/forum/viewtopic.php?id=31263 some users have received security warnings when using PHP 7.4. Updating PHPMailer to version 5.2.28 seems to remove the warning.
PHPMailer 5.2.28 is the latest version of branch 5.2 but there are much more recent versions 6.x. Piwigo does not include them because it would imply increasing the minimum PHP version to 5.5 at least, or maybe 7. We can plan that for Piwigo 12 or 13.